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1 1. Overview 

Introduction 

inSIDE HC08 is a basic debugger for Freescale HC08 family devices. inSIDE 
HC08 can be used in conjuction with the inDART-HC08 series of in-circuit, 
real-time, ISP debuggers/programmers to download and debug user 
applications directly into the target board, through a standard MON08 
connector. 

inSIDE HC08 can read binary, Intel-Hex, Freescale S-Record, P&E Map and 
ELF/DWARF files. inSIDE HC08 provides basic debugging capabilities (run, 
stop, single step, breakpoints, etc.) 

The inSIDE HC08 user interface is made of some hardware-specific functions 
(required to connect to and configure inDART-HC08) and some common 
functions related to the debug of the target application. The inDART-HC08-
specific functions are explained in detailed in the inDART-HC08 user’s manual. 
This chapter deals with all of the other inSIDE HC08 functions. 
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The inSIDE HC08 User Interface 

Installing the Software 

The inSIDE HC08 user interface setup program is located on the SofTec 
Microsystems “System Software” CD-ROM provided with the inDART-HC08 in-
circuit debugger/programmer. The setup program will copy the required files 
(including the USB driver) to your hard drive. Additionally, an uninstall 
program will be copied, giving you the option to uninstall the inSIDE HC08 user 
interface at any time. 

To install the inSIDE HC08 user interface: 

 

1. Insert the “System Software” CD-ROM into your computer’s CD-ROM 
drive. 

2. A startup window should automatically appear (if the startup window 
doesn’t appear automatically, manually run the Setup.exe file located on 
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1 the CD-ROM root). Choose “Install Instrument Software” from the 
main menu. 

3. A list of available software should appear. Click on the “inDART-HC08 
Additional Components” option. 

4. Follow the on-screen instructions. 

 

 
Note: if you are installing the inDART-HC08 user interface on Windows 2000 
or Windows XP you must have logged in as Administrator. 
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2. Starting Up a Debugging 
Session 

Creating a New Project 

Before starting a debugging session, you must create and configure a project. A 
project can be defined as a working session. Everything you do when working 
with the emulation unit, you do it within a project. 

A project contains all the information you need to work properly with the target: 
the microcontroller used, the working frequency and the source file, just to 
name a few. A project also contains user-specific information, such as 
breakpoint list and watch list, and environment options, such as type of 
windows displayed on the screen. When you open a project, all these 
information are automatically loaded, and automatically saved when another 
project is opened or you exit the inSIDE HC08 user interface. 

To create a new project, select Project > New from the main menu. The 
following dialog box will appear. 

 

 
The New Project Dialog Box 

First, assign the project a name. Then, specify a location. Click “OK” when 
done. inSIDE HC08 will create a .prj file with the project name you specified in 
the selected location. 
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Defining Project Properties 

After naming the new project, a Project Properties dialog box will appear. From 
this dialog box you can set all of the parameters that are required in order to 
correctly set up a debugging session. 

 

 
The Project Properties Dialog Box 

inSIDE HC08 supports binary, Intel-Hex, Freescale S-Record, P&E Map and 
ELF/DWARF files. Only P&E Map and ELF/DWARF object files contain debug 
information—therefore only these two formats allow source level debugging. For 
details on how to generate these object file, please consult your compiler’s 
documentation. 

Project Properties > MCU Configuration 
By clicking the “MCU Configuration” button in the Project Properties dialog 
box, a new dialog box will appear, allowing you to select the hardware model 
and the target microcontroller you are working with. 
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The MCU Configuration Dialog Box 

First, ensure that the “Hardware Model” parameter is set to “inDART-
HC08”. Then, set the “Device Code” parameter to the specific target 
microcontroller you are working with.  

MCU Configuration > Communication Settings 
The “Communication Settings” button in the MCU Configuration dialog 
box allows you to fine-tune critical parameters needed for proper operation with 
the chosen target microcontroller. 

 

 
The Communication Settings Dialog Box 

The dialog box is divided into three sections: “Communication Parameters”, 
“MON08 Settings” and “Power Supply Parameters”. All of the parameters must 
be carefully set, otherwise unsuccessful operations will result. For further 
details, please consult the inDART-HC08 user’s manual. 
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3. inSIDE HC08 Common 
Functions 

User Interface Overview 

The inSIDE HC08 user interface is organized in a series of windows that display 
various information about the emulation process. There are five types of 
different windows: Source, Registers, Disassembly, Memory, Watch. 

The inSIDE HC08 user interface provides a menu bar (from which you can 
access all of the user interface and emulation commands), a toolbar (which 
groups the most used commands) and a status bar (which shows information 
about your current emulation session). 

Managing inSIDE HC08 Windows 
The Window menu groups all the command related to the opening, closing and 
arranging of all of the inSIDE HC08 user interface windows. 

The Window > Cascade, Window > Horizontal Tile and Window > 
Vertical Tile commands arrange all of the open windows by respectively 
cascading, horizontal tiling and vertical tiling them. 

To save the current windows’ layout on the current project, select Window > 
Save Layout. Next time you open the project, the windows will open with the 
saved sizes and positions. 

The Window > Source command opens the Source window. Depending on 
the source file format you specified in the Project Properties dialog box, the 
Source window will contain your disassembled source code (without symbolic 
information), the Assembly source code or a complete C source code with 
symbolic information. The leftmost column of the Source window displays the 
current position of the Program Counter (indicated by an arrow) and the 
location of the breakpoint (if it has been set). 

The Window > Disassembly command opens the Disassembly window, 
which contains the disassembled project’s binary file. The disassembling starts 
from the current PC location and continues for a certain number of locations. A 
right-click on the Disassembly window opens the Debug menu. 
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Note: the Disassembly window is particularly useful when stepping on a C 
source file. inSIDE HC08’s step instructions (Step Into, Step Out, Step 
Over) actually step at the Assembly level. 
 
 

The Window > Memory command opens the Memory window, in which you 
have the possibility to view/edit the code/data, by simply double-clicking on a 
memory location and typing the new value. A right-click opens the Edit menu. 

 

 
Note: when the Memory window is open, step commands may execute slower, 
since the window contents need to be refreshed after every step. 
 
 

The Window > Registers command opens the Registers window, in which 
are displayed the target microcontroller’s registers. By double-clicking on a line 
on the Registers window you can edit its content. Alternatively, a right-click 
opens the Edit menu. 

The Window > Watch command opens the Watch window, which shows the 
list of all of the variables you added to the watch list, together with their address 
and their value in hexadecimal, decimal and binary format. You have the 
possibility to directly change the content of the variables, by simply double-
clicking on them and typing the new value. A right-click opens the Debug 
menu. 

User Interface Preferences 
The font used in the emulation windows can be customized with the Configure 
> Set Font command. In addition, the inSIDE HC08 user interface allows you 
to customize the background color and text color of each emulation window 
type—just choose the Configure > Set Colors command. 

Reloading/Reverting Source Code 
If you have modified the source code and you want to reload the last saved 
version, just select Project  > Reload Program. 

If the code has been changed by an external editor while inSIDE HC08 was 
running, you are requested to reload program when you re-enter in the user 
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interface. This allows you not to select File > Open again every time the source 
needs to be updated. 

Every time the source code is reloaded/reverted, inSIDE HC08 uploads the new 
source code into the emulation unit. 

Edit Commands 

All of the edit commands are located under the Edit menu. 

The Edit > Goto Address command (available when the Source, Disassembly 
or Memory window is active) moves the current visualization point to the 
specified address. 

The Edit > Set Program Counter command allows you to set a new value for 
the Program Counter. 

The Edit > Edit Data command (available when the Registers, Watch or 
Memory window is active) allows you to modify: 

 

� the value of the Program Counter or the value of a register, if you selected 
the corresponding item on the Registers window; 

� the value of a variable (if you are in the Watch window); 

� the content of the byte located at the selected memory location (if you are in 
the Memory window). 

 

In all of the above condition, a double-click on the item to be modified achieves 
the same result as selecting Edit > Edit Data. 

The Edit > Find command looks for a search pattern on the active window 
(this command is only available on the Source, Disassembly and Memory 
windows). 

The Edit > Registers... command opens the Edit Registers dialog box, which 
allows you to view/modify the contents of the target’s registers (it is the same as 
executing the Edit Data command when the Registers window is active). 
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The Edit Registers Dialog Box 

Debug Commands 

All of the debug commands are located under the Debug menu. 

The Debug  > Toggle Breakpoint command quickly toggles a breakpoint on 
the selected source code line in the Source window. 

The Debug  > Add Watch and Debug  > Delete Watch commands allows 
you to add/remove a variable on the Watch window. The content of the 
variables listed on the Watch window is updated every time the execution is 
stopped. 

The Debug  > Select Source File command can be used to open a different 
source code file belonging to the current project. This feature is only available 
for P&E Map and ELF/DWARF file-based projects. 

 

 
Note: if your project is made of several source code files, inSIDE HC08 always 
switches, during debugging, to the source code file which contains the 
instruction pointed to by the Program Counter. 
 

Run Commands 

All of the commands related to run/stop the emulation are located under the 
Run menu. 

The Run > Reset Processor command resets the instrument. The operation 
is the equivalent of asserting a RESET signal on the HC08 family of 
microcontrollers. All registers and flags are set to their default values. 

The Run > Go From Reset command resets the instrument and then runs 
your program. Selecting Run > Go From Reset is the equivalent of selecting 
the Reset Processor command followed by Go command. 
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The Run > Go command starts execution from the current Program Counter. 
inSIDE HC08 executes the program until you interrupt it, until it reaches a 
breakpoint, or until the program terminates. 

The Run > Go From New PC command allows you to run your program 
starting from a specified location. If you select this command, a dialog box 
appears asking you from where you want your program to start. If a debug code 
is loaded, you’ll find here a list of labels. You can specify one of these labels as 
the starting value for the Program Counter. 

The Run > Stop command stops the current emulation session. To continue 
the execution of the program just select Go. 

The Run > Step Into command causes inSIDE HC08 to execute a single 
instruction. If the Source or Disassembly window is open, the next instruction 
to be executed will be highlighted (the arrow of the Program Counter also points 
to this line). 

The Run > Step Over command executes a single line of your program and 
skips over any procedure or function calls. If the next executable instruction is a 
BSR instruction, selecting Step Over will cause the debugger to step over the 
routine being called (but fully executing it) and return to the line directly 
beneath the BSR instruction. If the Source or Disassembly window is open, the 
next instruction to be executed will be highlighted (the arrow of the Program 
Counter also points to this line). 

The Run > Step Out command works in the same way of Step Into, but if it's 
invoked inside a subroutine causes the rest of the procedure to be executed, 
returning to the instruction right beneath the BSR instruction. If the Source or 
Disassembly window is open, the next instruction to be executed will be 
highlighted (the arrow of the Program Counter also points to this line). 

 

 
Note: the Step Out command only works if the stack pointer has not been 
modified inside the subroutine. 
 
 

The Run > Multiple Step command causes a specified number of instructions 
to be executed. You can specify  this number by selecting the Run > Multiple 
Step Value command. 
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4. Troubleshooting 

Common Problems and Solutions 

This section reports some common problems that may arise during general use. 
However, working with a specific target device may cause device-specific issues. 

Communication Can’t Be Established with inDART-HC08 
1. Make sure the inDART-HC08 in-circuit debugger is connected to the PC 

and powered on. inDART-HC08 is powered by the USB connection.  

2. Make sure you are working with the correct inDART hardware model. To 
view/change the inDART hardware model in use, choose Project > 
Properties from the inSIDE HC08 user interface’s main menu and click 
the “MCU Configuration” button. 

3. Make sure the demo board/target application board is powered on and the 
target microcontroller is working. Programming and debugging rely on a 
MON08 serial communication between the inDART-HC08 board and the 
demo board/target application. This means that, in order to work correctly, 
the target microcontroller must be running. In particular, make sure that: 
 

� The MON08 cable is connected to the demo board/target application’s 
MON08 connector. 

� The target microcontroller is in place. 

� All of the MON08 connector signals are correctly tied to the target 
microcontroller. 

� The TGT_IRQ# and the RST_IN# MON08 lines aren’t driven low by 
the target. 

� The oscillator circuitry is working at the frequency required to generate 
the specified MON08 target’s baud rate. To view/change the MON08 
baud rate, choose Project > Properties from the inSIDE HC08 user 
interface’s main menu and click the “Communication Settings” 
button. 

 

4. Make sure that the target baud rate setting, required to enter the monitor 
mode, has been calculated taking into account the “Frequency divider” 
parameter (in the Communication Settings dialog box). 
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A Communication Error Is Returned on a Program Execution Command 
(Go, Step, etc.) 
� Make sure that the target microcontroller’s I/O bit corresponding to the 

MON08 line dedicated to the bidirectional communication is set to input by 
your program. 

� Make sure that your program works correctly. Among other things, your 
program must not access reserved memory locations. 

Peripheral Speed is Low 
The “Frequency divider” parameter should always be set to 4 in order to 
guarantee that, in monitor mode, all of the target microcontroller’s peripherals 
run at the same speed they do in user mode. If, however, you set this parameter 
to 2 not all peripherals will work at this doubled speed. 

Stepping Execution is Slow 
When the Memory window is open, step commands may execute slower, since 
the Memory window contents need to be refreshed after every step. 

Getting Technical Support 

Technical assistance is provided free to all customers. For technical assistance, 
documentation and information about products and services, please refer to 
your local SofTec Microsystems partner. 

To benefit the free technical support service, the Registration Card must have 
been filled out and sent in. 

SofTec Microsystems offers its customers a free technical support service at 
support@softecmicro.com. Before to get in contact with us we suggest you, 
however, to visit our online FAQ section and to be sure you are working with the 
latest version of the inDART-HC08 user interface (upgrades are available for 
free at http://www.softecmicro.com/download.html)




